top of page

DMVPN and Multicast2 (Use NBMA Mode)

HQ:R1 RP

BRANCH-B:R33 Multicast Source BRANCH-A:R22 Multicast Receiver-A

R1

interface Tunnel0 ip address 10.0.0.1 255.255.255.0 ip nhrp map multicast dynamic ip nhrp network-id 123

ip nhrp redirect

ip ospf network point-to-multipoint

tunnel mode gre multipoint

tunnel source FastEthernet0/0

interface FastEthernet0/0 ip address 155.0.0.1 255.255.255.0

interface FastEthernet0/1 ip address 192.168.1.1 255.255.255.0

router ospf 123 router-id 1.1.1.1 network 10.0.0.1 0.0.0.0 area 0 network 192.168.1.1 0.0.0.0 area 0

R2

interface Tunnel0 ip address 10.0.0.2 255.255.255.0 no ip redirects ip nhrp map multicast 155.0.0.1 ip nhrp map 10.0.0.1 155.0.0.1 ip nhrp network-id 123 ip nhrp nhs 10.0.0.1

ip nhrp shortcut ip ospf network point-to-multipoint tunnel mode gre multipoint

tunnel source FastEthernet0/0

interface FastEthernet0/0 ip address 155.0.0.2 255.255.255.0

interface FastEthernet0/1 ip address 192.168.2.2 255.255.255.0

router ospf 123 router-id 2.2.2.2 network 10.0.0.2 0.0.0.0 area 0 network 192.168.2.2 0.0.0.0 area 0

R3 interface Tunnel0 ip address 10.0.0.3 255.255.255.0 no ip redirects ip nhrp map multicast 155.0.0.1 ip nhrp map 10.0.0.1 155.0.0.1 ip nhrp network-id 123 ip nhrp nhs 10.0.0.1

ip nhrp shortcut ip ospf network point-to-multipoint tunnel mode gre multipoint

tunnel source FastEthernet0/0

interface FastEthernet0/0 ip address 155.0.0.3 255.255.255.0

interface FastEthernet0/1 ip address 192.168.3.3 255.255.255.0

router ospf 123 router-id 3.3.3.3 network 10.0.0.3 0.0.0.0 area 0 network 192.168.3.3 0.0.0.0 area 0

R1/R2/R3

ip multicast-routing

crypto isakmp policy 123

encr 3des hash sha256 authentication pre-share group 2

crypto isakmp key CCIE address 0.0.0.0

crypto ipsec transform-set TRANS esp-3des esp-sha256-hmac mode transport

crypto ipsec profile PROFILE set transform-set TRANS

interface Tunnel0 tunnel protection ipsec profile PROFILE ip pim sparse-mode

interface FastEthernet0/1 ip pim sparse-mode

ip pim rp-address 10.0.0.1

R11 interface FastEthernet0/0 ip address 192.168.1.11 255.255.255.0

ip route 0.0.0.0 0.0.0.0 192.168.1.1

R22 interface FastEthernet0/0 ip address 192.168.2.22 255.255.255.0

ip route 0.0.0.0 0.0.0.0 192.168.2.2

R33 interface FastEthernet0/0 ip address 192.168.3.33 255.255.255.0

ip route 0.0.0.0 0.0.0.0 192.168.3.3

R1#show dmvpn

Interface: Tunnel0, IPv4 NHRP Details Type:Hub, NHRP Peers:2,

# Ent Peer NBMA Addr Peer Tunnel Add State UpDn Tm Attrb ----- --------------- --------------- ----- -------- ----- 1 155.0.0.2 10.0.0.2 UP 00:00:29 D 1 155.0.0.3 10.0.0.3 UP 00:00:34 D

Configure ip igmp join-group command on R22.

R22 interface FastEthernet0/0 ip igmp join-group 239.255.1.1

show ip mroute

R2#sh ip mroute

(*, 239.255.1.1), 00:29:33/00:02:27, RP 10.0.0.1, flags: SJC Incoming interface: Tunnel0, RPF nbr 10.0.0.1 Outgoing interface list: FastEthernet0/1, Forward/Sparse, 00:29:33/00:02:27

(*, 224.0.1.40), 00:29:35/00:02:26, RP 10.0.0.1, flags: SJCL Incoming interface: Tunnel0, RPF nbr 10.0.0.1 Outgoing interface list: FastEthernet0/1, Forward/Sparse, 00:29:34/00:02:26

R3#sh ip mroute

(*, 224.0.1.40), 00:30:38/00:02:30, RP 10.0.0.1, flags: SJCL Incoming interface: Tunnel0, RPF nbr 10.0.0.1 Outgoing interface list: FastEthernet0/1, Forward/Sparse, 00:30:37/00:02:30

R1#sh ip mroute

(*, 239.255.1.1), 00:29:37/00:03:20, RP 10.0.0.1, flags: S Incoming interface: Null, RPF nbr 0.0.0.0 Outgoing interface list: Tunnel0, Forward/Sparse, 00:01:08/00:03:20

(*, 224.0.1.40), 00:30:54/00:03:20, RP 10.0.0.1, flags: SJCL Incoming interface: Null, RPF nbr 0.0.0.0 Outgoing interface list: Tunnel0, Forward/Sparse, 00:01:14/00:03:20 FastEthernet0/1, Forward/Sparse, 00:30:53/00:02:13

R1 receive a PIM (*,G) join message from R2,

and include Tunnel 0 interface to OIL.

Send multicast packets

R33#ping 239.255.1.1 Type escape sequence to abort. Sending 1, 100-byte ICMP Echos to 239.255.1.1, timeout is 2 seconds:

.

show ip mroute

R3#sh ip mroute

(*, 239.255.1.1), 00:00:34/stopped, RP 10.0.0.1, flags: SPF Incoming interface: Tunnel0, RPF nbr 10.0.0.1 Outgoing interface list: Null

(192.168.3.33, 239.255.1.1), 00:00:34/00:02:26, flags: FT Incoming interface: FastEthernet0/1, RPF nbr 0.0.0.0 Outgoing interface list: Tunnel0, Forward/Sparse, 00:00:22/00:03:07

(*, 224.0.1.40), 00:00:57/00:02:28, RP 10.0.0.1, flags: SJCL Incoming interface: Tunnel0, RPF nbr 10.0.0.1 Outgoing interface list: FastEthernet0/1, Forward/Sparse, 00:00:57/00:02:28

R2#sh ip mroute

(*, 239.255.1.1), 00:01:18/00:02:36, RP 10.0.0.1, flags: SJC Incoming interface: Tunnel0, RPF nbr 10.0.0.1 Outgoing interface list: FastEthernet0/1, Forward/Sparse, 00:01:18/00:02:36

(*, 224.0.1.40), 00:01:47/00:02:36, RP 10.0.0.1, flags: SJCL Incoming interface: Tunnel0, RPF nbr 10.0.0.1 Outgoing interface list: FastEthernet0/1, Forward/Sparse, 00:01:47/00:02:36

R1#sh ip mroute

(*, 239.255.1.1), 00:01:02/00:02:38, RP 10.0.0.1, flags: S Incoming interface: Null, RPF nbr 0.0.0.0 Outgoing interface list: Tunnel0, Forward/Sparse, 00:00:51/00:02:38

(192.168.3.33, 239.255.1.1), 00:01:02/00:01:57, flags: PX Incoming interface: Tunnel0, RPF nbr 10.0.0.3 Outgoing interface list: Null

(*, 224.0.1.40), 00:01:17/00:03:08, RP 10.0.0.1, flags: SJCL Incoming interface: Null, RPF nbr 0.0.0.0 Outgoing interface list: Tunnel0, Forward/Sparse, 00:00:27/00:03:08 FastEthernet0/1, Forward/Sparse, 00:01:17/00:02:01

R3 send multicast packets capsuled as a register message to RP because it is First Hop Router .

R1 receive a register message,

and include Tunnel 0 interface to incoming interface.

The OIL on R1 become Null

because R1 can NOT include same interface for incoming interface and OIL.

Configure ip pim nbma-mode command for tunnel 0 interface on R1

R1

interface Tunnel0 ip pim nbma-mode

Send multicast packets

R33#ping 239.255.1.1 Type escape sequence to abort. Sending 1, 100-byte ICMP Echos to 239.255.1.1, timeout is 2 seconds:

Reply to request 0 from 192.168.2.22, 1076 ms

R1#sh ip mroute

(*, 239.255.1.1), 00:01:00/stopped, RP 10.0.0.1, flags: S Incoming interface: Null, RPF nbr 0.0.0.0 Outgoing interface list: Tunnel0, 10.0.0.2, Forward/Sparse, 00:01:00/00:02:44

(192.168.3.33, 239.255.1.1), 00:00:30/00:02:29, flags: Incoming interface: Tunnel0, RPF nbr 10.0.0.3 Outgoing interface list: Tunnel0, 10.0.0.2, Forward/Sparse, 00:00:30/00:02:59

(*, 224.0.1.40), 00:01:04/00:02:43, RP 10.0.0.1, flags: SJCL Incoming interface: Null, RPF nbr 0.0.0.0 Outgoing interface list: Tunnel0, 10.0.0.3, Forward/Sparse, 00:00:46/00:02:43 Tunnel0, 10.0.0.2, Forward/Sparse, 00:00:49/00:02:40 FastEthernet0/1, Forward/Sparse, 00:01:04/00:02:08

R1 can identify IP address that sent each message, even if it receives PIM Join and a register message via same interface.

Therefore R1 can receicve and send multicast pakets via an interface, tunnel 0.

Related page

最新記事
アーカイブ
タグから検索
ソーシャルメディア
  • Facebook Basic Square
  • Twitter Basic Square
  • Google+ Basic Square
bottom of page