DMVPN and Multicast(Static RP)
HQ:R11 Multicast Source BRANCH-A:R22 Multicast Receiver-A BRANCH-B:R33 Multicast Receiver-B
R1 interface Tunnel0 ip address 10.0.0.1 255.255.255.0 ip nhrp map multicast dynamic ip nhrp network-id 123
ip nhrp redirect
ip ospf network point-to-multipoint
tunnel mode gre multipoint
tunnel source FastEthernet0/0
interface FastEthernet0/0 ip address 155.0.0.1 255.255.255.0
interface FastEthernet0/1 ip address 192.168.1.1 255.255.255.0
router ospf 123 router-id 1.1.1.1 network 10.0.0.1 0.0.0.0 area 0 network 192.168.1.1 0.0.0.0 area 0
R2
interface Tunnel0 ip address 10.0.0.2 255.255.255.0 no ip redirects ip nhrp map multicast 155.0.0.1 ip nhrp map 10.0.0.1 155.0.0.1 ip nhrp network-id 123 ip nhrp nhs 10.0.0.1
ip nhrp shortcut ip ospf network point-to-multipoint tunnel mode gre multipoint
tunnel source FastEthernet0/0
interface FastEthernet0/0 ip address 155.0.0.2 255.255.255.0
interface FastEthernet0/1 ip address 192.168.2.2 255.255.255.0
router ospf 123 router-id 2.2.2.2 network 10.0.0.2 0.0.0.0 area 0 network 192.168.2.2 0.0.0.0 area 0
R3 interface Tunnel0 ip address 10.0.0.3 255.255.255.0 no ip redirects ip nhrp map multicast 155.0.0.1 ip nhrp map 10.0.0.1 155.0.0.1 ip nhrp network-id 123 ip nhrp nhs 10.0.0.1
ip nhrp shortcut ip ospf network point-to-multipoint tunnel mode gre multipoint
tunnel source FastEthernet0/0
interface FastEthernet0/0 ip address 155.0.0.3 255.255.255.0
interface FastEthernet0/1 ip address 192.168.3.3 255.255.255.0
router ospf 123 router-id 3.3.3.3 network 10.0.0.3 0.0.0.0 area 0 network 192.168.3.3 0.0.0.0 area 0
R1/R2/R3 crypto isakmp policy 123 encr 3des hash sha256 authentication pre-share group 2
crypto isakmp key CCIE address 0.0.0.0
crypto ipsec transform-set TRANS esp-3des esp-sha256-hmac mode transport
crypto ipsec profile PROFILE set transform-set TRANS
interface Tunnel0 tunnel protection ipsec profile PROFILE
Vefify
R1#sh dmvpn
==========================================================================
Interface: Tunnel0, IPv4 NHRP Details Type:Hub, NHRP Peers:2,
# Ent Peer NBMA Addr Peer Tunnel Add State UpDn Tm Attrb ----- --------------- --------------- ----- -------- ----- 1 155.0.0.2 10.0.0.2 UP 00:51:59 D 1 155.0.0.3 10.0.0.3 UP 00:52:20 D
Configure R11, R22, R33
R11 interface FastEthernet0/0 ip address 192.168.1.11 255.255.255.0
ip route 0.0.0.0 0.0.0.0 192.168.1.1
R22 interface FastEthernet0/0 ip address 192.168.2.22 255.255.255.0
ip route 0.0.0.0 0.0.0.0 192.168.2.2
R33 interface FastEthernet0/0 ip address 192.168.3.33 255.255.255.0
ip route 0.0.0.0 0.0.0.0 192.168.3.3
R11#traceroute 192.168.2.22 Type escape sequence to abort. Tracing the route to 192.168.2.22 VRF info: (vrf in name/id, vrf out name/id) 1 192.168.1.1 60 msec 28 msec 72 msec 2 10.0.0.2 168 msec 112 msec 180 msec 3 192.168.2.22 120 msec 164 msec 112 msec
R11#traceroute 192.168.3.33 Type escape sequence to abort. Tracing the route to 192.168.3.33 VRF info: (vrf in name/id, vrf out name/id) 1 192.168.1.1 48 msec 68 msec 40 msec 2 10.0.0.3 180 msec 164 msec 196 msec 3 192.168.3.33 244 msec 108 msec 108 msec
Communicate SPOKE to SPOKE
R22#traceroute 192.168.3.33 Type escape sequence to abort. Tracing the route to 192.168.3.33 VRF info: (vrf in name/id, vrf out name/id) 1 192.168.2.2 52 msec 60 msec 60 msec 2 10.0.0.1 144 msec 184 msec 136 msec 3 10.0.0.3 312 msec 504 msec 448 msec 4 192.168.3.33 392 msec 564 msec 576 msec
R2#sh ip route ospf
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks O 10.0.0.1/32 [110/1000] via 10.0.0.1, 00:03:13, Tunnel0 O 10.0.0.3/32 [110/2000] via 10.0.0.1, 00:03:13, Tunnel0 O 192.168.1.0/24 [110/1001] via 10.0.0.1, 00:03:13, Tunnel0 O % 192.168.3.0/24 [110/2001] via 10.0.0.1, 00:03:13, Tunnel0
R22#traceroute 192.168.3.33 Type escape sequence to abort. Tracing the route to 192.168.3.33 VRF info: (vrf in name/id, vrf out name/id) 1 192.168.2.2 72 msec 40 msec 32 msec 2 10.0.0.3 148 msec 124 msec 132 msec 3 192.168.3.33 108 msec 60 msec 104 msec
SPOKE can communicate directly.
Configure Multicast Static RP
RP: R1 tunnel0
R1/R2/R3 ip multicast-routing
interface Tunnel0 ip pim sparse-mode
interface FastEthernet0/1 ip pim sparse-mode
ip pim rp-address 10.0.0.1
show ip mroute
R1#sh ip mroute IP Multicast Routing Table
(*, 224.0.1.40), 00:05:32/00:02:46, RP 10.0.0.1, flags: SJCL Incoming interface: Null, RPF nbr 0.0.0.0 Outgoing interface list: Tunnel0, Forward/Sparse, 00:00:27/00:03:15 FastEthernet0/1, Forward/Sparse, 00:05:29/00:02:28
R2#sh ip mroute
(*, 224.0.1.40), 00:01:40/00:02:36, RP 10.0.0.1, flags: SJPCL Incoming interface: Tunnel0, RPF nbr 10.0.0.1 Outgoing interface list: Null
R3#sh ip mroute
(*, 224.0.1.40), 00:01:48/00:02:09, RP 10.0.0.1, flags: SJPCL Incoming interface: Tunnel0, RPF nbr 10.0.0.1 Outgoing interface list: Null
show ip pim rp mapping
R1#sh ip pim rp mapping PIM Group-to-RP Mappings
Group(s): 224.0.0.0/4, Static RP: 10.0.0.1 (?)
R2#sh ip pim rp mapping PIM Group-to-RP Mappings
Group(s): 224.0.0.0/4, Static RP: 10.0.0.1 (?)
R3#sh ip pim rp mapping PIM Group-to-RP Mappings
Group(s): 224.0.0.0/4, Static RP: 10.0.0.1 (?)
show ip pim neighbor
R1#sh ip pim neighbor PIM Neighbor Table
Neighbor Interface Uptime/Expires Ver DR Address Prio/Mode 10.0.0.3 Tunnel0 00:06:26/00:01:42 v2 1 / DR S P G 10.0.0.2 Tunnel0 00:06:36/00:01:31 v2 1 / S P G
R2#sh ip pim neighbor PIM Neighbor Table
Neighbor Interface Uptime/Expires Ver DR Address Prio/Mode 10.0.0.1 Tunnel0 00:07:12/00:01:34 v2 1 / S P G
R3#sh ip pim neighbor PIM Neighbor Table
Neighbor Interface Uptime/Expires Ver DR Address Prio/Mode 10.0.0.1 Tunnel0 00:08:36/00:01:29 v2 1 / S P
show ip igmp groups
R2#sh ip igmp groups IGMP Connected Group Membership Group Address Interface Uptime Expires Last Reporter Group Accounted 224.0.1.40 Tunnel0 00:09:52 00:02:16 10.0.0.2
R3#sh ip igmp groups IGMP Connected Group Membership Group Address Interface Uptime Expires Last Reporter Group Accounted 224.0.1.40 Tunnel0 00:10:04 00:02:01 10.0.0.3
Send multicast packets
R11#ping 239.255.1.1 Type escape sequence to abort. Sending 1, 100-byte ICMP Echos to 239.255.1.1, timeout is 2 seconds: .
R1#sh ip mroute IP Multicast Routing Table
(*, 239.255.1.1), 00:00:59/stopped, RP 10.0.0.1, flags: SP Incoming interface: Null, RPF nbr 0.0.0.0 Outgoing interface list: Null
(192.168.1.11, 239.255.1.1), 00:00:59/00:02:00, flags: PT Incoming interface: FastEthernet0/1, RPF nbr 0.0.0.0 Outgoing interface list: Null
(*, 224.0.1.40), 00:17:06/00:02:59, RP 10.0.0.1, flags: SJCL Incoming interface: Null, RPF nbr 0.0.0.0 Outgoing interface list: Tunnel0, Forward/Sparse, 00:12:02/00:03:26 FastEthernet0/1, Forward/Sparse, 00:17:04/00:02:59
R2#sh ip mroute IP Multicast Routing Table
(*, 224.0.1.40), 00:12:28/00:02:42, RP 10.0.0.1, flags: SJPCL Incoming interface: Tunnel0, RPF nbr 10.0.0.1 Outgoing interface list: Null
R3#sh ip mroute
(*, 224.0.1.40), 00:14:26/00:02:32, RP 10.0.0.1, flags: SJPCL Incoming interface: Tunnel0, RPF nbr 10.0.0.1 Outgoing interface list: Null
Set ip igmp join-group command on R22/R33
R22/R33 interface FastEthernet0/0 ip igmp join-group 239.255.1.1
R2#sh ip mroute IP Multicast Routing Table
(*, 239.255.1.1), 00:01:11/00:02:44, RP 10.0.0.1, flags: SJC Incoming interface: Tunnel0, RPF nbr 10.0.0.1 Outgoing interface list: FastEthernet0/1, Forward/Sparse, 00:01:11/00:02:44
(*, 224.0.1.40), 00:17:17/00:02:53, RP 10.0.0.1, flags: SJPCL Incoming interface: Tunnel0, RPF nbr 10.0.0.1 Outgoing interface list: Null
R3#sh ip mroute IP Multicast Routing Table
(*, 239.255.1.1), 00:01:19/00:01:58, RP 10.0.0.1, flags: SJC Incoming interface: Tunnel0, RPF nbr 10.0.0.1 Outgoing interface list: FastEthernet0/1, Forward/Sparse, 00:01:19/00:01:58
(*, 224.0.1.40), 00:18:03/00:02:56, RP 10.0.0.1, flags: SJPCL Incoming interface: Tunnel0, RPF nbr 10.0.0.1 Outgoing interface list: Null
Send multicast packets again
R11#ping 239.255.1.1 Type escape sequence to abort. Sending 1, 100-byte ICMP Echos to 239.255.1.1, timeout is 2 seconds:
Reply to request 0 from 192.168.3.33, 548 ms Reply to request 0 from 192.168.2.22, 716 ms
show ip mroute
R1#sh ip mroute IP Multicast Routing Table
(*, 239.255.1.1), 00:08:15/00:03:12, RP 10.0.0.1, flags: S Incoming interface: Null, RPF nbr 0.0.0.0 Outgoing interface list: Tunnel0, Forward/Sparse, 00:03:13/00:03:12
(192.168.1.11, 239.255.1.1), 00:00:43/00:02:16, flags: T Incoming interface: FastEthernet0/1, RPF nbr 0.0.0.0 Outgoing interface list: Tunnel0, Forward/Sparse, 00:00:43/00:03:12
(*, 224.0.1.40), 00:24:23/00:02:52, RP 10.0.0.1, flags: SJCL Incoming interface: Null, RPF nbr 0.0.0.0 Outgoing interface list: Tunnel0, Forward/Sparse, 00:19:19/00:03:00 FastEthernet0/1, Forward/Sparse, 00:24:21/00:02:44
R2#sh ip mroute IP Multicast Routing Table
(*, 239.255.1.1), 00:03:40/stopped, RP 10.0.0.1, flags: SJC Incoming interface: Tunnel0, RPF nbr 10.0.0.1 Outgoing interface list: FastEthernet0/1, Forward/Sparse, 00:03:40/00:02:20
(192.168.1.11, 239.255.1.1), 00:01:09/00:01:50, flags: JT Incoming interface: Tunnel0, RPF nbr 10.0.0.1 Outgoing interface list: FastEthernet0/1, Forward/Sparse, 00:01:09/00:02:20
(*, 224.0.1.40), 00:19:45/00:02:22, RP 10.0.0.1, flags: SJPCL Incoming interface: Tunnel0, RPF nbr 10.0.0.1 Outgoing interface list: Null
R3#sh ip mroute IP Multicast Routing Table
(*, 239.255.1.1), 00:03:08/stopped, RP 10.0.0.1, flags: SJC Incoming interface: Tunnel0, RPF nbr 10.0.0.1 Outgoing interface list: FastEthernet0/1, Forward/Sparse, 00:03:08/00:02:18
(192.168.1.11, 239.255.1.1), 00:01:25/00:01:34, flags: JT Incoming interface: Tunnel0, RPF nbr 10.0.0.1 Outgoing interface list: FastEthernet0/1, Forward/Sparse, 00:01:25/00:02:18
(*, 224.0.1.40), 00:19:52/00:02:09, RP 10.0.0.1, flags: SJPCL Incoming interface: Tunnel0, RPF nbr 10.0.0.1 Outgoing interface list: Null
Remove IPsec from Tunnel 0 Interfaces
R1/R2/R3 int tunnel0 no tunnel protection ipsec profile PROFILE
R11#ping 239.255.1.1 Type escape sequence to abort. Sending 1, 100-byte ICMP Echos to 239.255.1.1, timeout is 2 seconds:
Reply to request 0 from 192.168.2.22, 616 ms Reply to request 0 from 192.168.3.33, 696 ms